MovableType 7のインストールで「必要なモジュールが見つかりません~HTML::Entities」というエラーになる場合の対処

MovableType 7のインストールで「必要なモジュールが見つかりません~HTML::Entities」というエラーになる場合の対処

Posted at December 27,2018 12:03 AM
Tag:[MovableType, TroubleShooting]

MovableType 7のインストールで「必要なモジュールが見つかりません~HTML::Entities」というエラーになる場合の対処方法を紹介します。

1.問題点

自宅のPCにMovableType 7をインストールしようとしたところ、下記のようなエラーに遭遇しました。

必要なモジュールが見つかりません
HTML::Entities
HTML::Entitiesは、CGI.pm の動作に必要です。
必須バージョン: 3.69

(クリックで拡大、以下同様)
必要なモジュールが見つかりません<

どうやら自分の環境にインストールされているHTML::Entitiesのバージョンが3.69より古いようです。

ということで、MovableType 7のインストールで「HTML::Entities」のバージョンエラーになる場合の対処方法を紹介します。

2.対処方法

CPANの「HTML::Parser」のページにアクセスして、「Download」をクリック(執筆時点のバージョンは3.72)。

CPANの「HTML::Parser」のページ

ダウンロードしたアーカイブを展開して、HTML-Parser-3.72/lib/HTML配下の下記のファイルを、MovableType 7のextlib/HTMLにアップロード。

  • Entities.pm
  • Filter.pm
  • HeadParser.pm
  • LinkExtor.pm
  • PullParser.pm
  • TokeParser.pm

extlib/HTML

これで再度インストールを実施すればエラーが解消します。

エラーが解消

3.参考サイト

参考サイトは下記です。ありがとうございました。

MTQ:Movable Type7 HTML::Entitiesのバージョンエラー

関連記事
zenback
人気エントリー
トラックバックURL


コメントする
greeting

*必須

*必須(非表示)


ご質問のコメントの回答については、内容あるいは多忙の場合、1週間以上かかる場合があります。また、すべてのご質問にはお答えできない可能性があります。予めご了承ください。

太字イタリックアンダーラインハイパーリンク引用
[サインインしない場合はここにCAPTCHAを表示します]

コメント投稿後にScript Errorや500エラーが表示された場合は、すぐに再送信せず、ブラウザの「戻る」ボタンで一旦エントリーのページに戻り(プレビュー画面で投稿した場合は、投稿内容をマウスコピーしてからエントリーのページに戻り)、ブラウザをリロードして投稿コメントが反映されていることを確認してください。

コメント欄に(X)HTMLタグやMTタグを記述される場合、「<」は「&lt;」、「>」は「&gt;」と入力してください。例えば「<$MTBlogURL$>」は「&lt;$MTBlogURL$&gt;」となります(全て半角文字)