Firefox16でMovable Typeのカテゴリ・フォルダ選択ができない不具合について(続き:パッチの適用バージョン調査)

Firefox16でMovable Typeのカテゴリ・フォルダ選択ができない不具合について(続き:パッチの適用バージョン調査)

Posted at October 22,2012 1:55 AM
Tag:[Firefox, MovableType, TroubleShooting]

Firefox16の使用で、Movable Typeの記事編集画面でカテゴリ・フォルダ選択ができない問題が発生しており、公式サイトの以下のページで対処パッチがリリースされています。

Firefox 16 でカテゴリおよびフォルダの選択が保存できない。
Firefox 16 でカテゴリおよびフォルダの選択が保存できない。

提供されているのは以下の2ファイルです。

  • mt-static/js/mt_core_compact.js
  • mt-static/js/common/List.js

ただし、提供されているパッチは以下のバージョンしか指定されておりません。

  • Movable Type 4.38
  • Movable Type 5.07
  • Movable Type 5.14
  • Movable Type 5.2

該当するバージョンを利用中でない場合、MTのアップグレードが必要みたいですが、簡単にアップグレードできないケースも多いと思います。

ということで、他のバージョンで適用可能かどうか、以下のソースコード差分について調査してみました。MT4系は未調査です。

  • MT5.14のmt_core_compact.js(修正前)とMT5.13以前のmt_core_compact.jsの差分
  • MT5.14のList.js(修正前)とMT5.13以前のList.jsの差分
  • MT5.07のmt_core_compact.js(修正前)とMT5.07以前のmt_core_compact.jsの差分
  • MT5.07のList.js(修正前)とMT5.07以前のList.jsの差分

差分がなければ提供されているパッチが利用可能と思われます。

1.MT5.14のmt_core_compact.js(修正前)とMT5.13以前のmt_core_compact.jsの差分

MT5.14のmt_core_compact.js(修正前)とMT5.13以前のmt_core_compact.jsの差分です。

バージョン差分
MT-5.13-jaなし
MT-5.12-jaあり
MT-5.11-jaあり
MT-5.1-jaあり

「差分あり」の分については5項を参照願います。

2.MT5.14のList.js(修正前)とMT5.13以前のList.jsの差分

MT5.14のList.js(修正前)とMT5.13以前のList.jsの差分です。

バージョン差分
MT-5.13-jaなし
MT-5.12-jaなし
MT-5.11-jaなし
MT-5.1-jaなし

すべてのバージョンでパッチが利用できると思われます。

3.MT5.07のmt_core_compact.js(修正前)とMT5.07以前のmt_core_compact.jsの差分

MT5.07のmt_core_compact.js(修正前)とMT5.07以前のmt_core_compact.jsの差分です。

バージョン差分
MT-5.06-jaなし
MT-5.051-jaなし
MT-5.05-jaなし
MT-5.04-jaなし
MT-5.031-jaなし
MT-5.03-jaなし
MT-5.02-jaなし
MT-5.01-jaなし
MT-5.0-jaなし

すべてのバージョンでパッチが利用できると思われます。

4.MT5.07のList.js(修正前)とMT5.07以前のList.jsの差分

MT5.07のList.js(修正前)とMT5.07以前のList.jsの差分です。

バージョン差分
MT-5.06-jaなし
MT-5.051-jaなし
MT-5.05-jaなし
MT-5.04-jaなし
MT-5.031-jaなし
MT-5.03-jaなし
MT-5.02-jaなし
MT-5.01-jaなし
MT-5.0-jaなし

すべてのバージョンでパッチが利用できると思われます。

5.MT-5.1/MT-5.11/MT-5.12のパッチ

MT-5.1/MT-5.11/MT-5.12のmt_core_compact.jsについては差分があったため、Movable Type 5.14用のmt_core_compact.jsの修正箇所をMT-5.1/MT-5.11/MT-5.12のmt_core_compact.jsに適用したパッチを作ってみました。

mt_core_compact.js(MT-5.1/MT-5.11/MT-5.12用)

パッチはMT-5.12で動作確認しています。が、ご利用は自己責任でお願いします。

なお、Movable Type 5.14用パッチをMT-5.12適用しても動作することを確認しています。こちらも自己責任でお願い致します。

関連記事
zenback
人気エントリー
トラックバックURL


コメント

お久しぶりです。
Movable Type 4.38 をversion 4.25 のフォルダにそのまま入れてみましたが、問題なく今のところ動いているようです。

[1] Posted by KlingonEmpire logo : October 31, 2012 12:51 PM

>KlingonEmpireさん
ご無沙汰しています。
ご返事遅くなって大変申しわけありません!
ご連絡ありがとうございました!

[2] Posted by yujiro logo : November 14, 2012 9:57 PM
コメントする
greeting

*必須

*必須(非表示)


ご質問のコメントの回答については、内容あるいは多忙の場合、1週間以上かかる場合があります。また、すべてのご質問にはお答えできない可能性があります。予めご了承ください。

太字イタリックアンダーラインハイパーリンク引用
[サインインしない場合はここにCAPTCHAを表示します]

コメント投稿後にScript Errorや500エラーが表示された場合は、すぐに再送信せず、ブラウザの「戻る」ボタンで一旦エントリーのページに戻り(プレビュー画面で投稿した場合は、投稿内容をマウスコピーしてからエントリーのページに戻り)、ブラウザをリロードして投稿コメントが反映されていることを確認してください。

コメント欄に(X)HTMLタグやMTタグを記述される場合、「<」は「&lt;」、「>」は「&gt;」と入力してください。例えば「<$MTBlogURL$>」は「&lt;$MTBlogURL$&gt;」となります(全て半角文字)